Proof of Claim Training Video

To view on-line training, Adobe Flash Player 8.0 or later is required. If it is not installed on your computer, you should be prompted to download the free player. The guides include audio so be sure to enable sound on your computers.

Content on this page requires a newer version of Adobe Flash Player.

Get Adobe Flash player